A WordPress-centric search engine for devs and theme authors



wp_is_auto_update_forced_for_item ›

Since5.6.0
Deprecatedn/a
wp_is_auto_update_forced_for_item ( $type, $update, $item )
Parameters: (3)
  • (string) $type The type of update being checked: 'theme' or 'plugin'.
    Required: Yes
  • (bool|null) $update Whether to update. The value of null is internally used to detect whether nothing has hooked into this filter.
    Required: Yes
  • (object) $item The update offer.
    Required: Yes
Returns:
  • (bool) True if auto-updates are forced for `$item`, false otherwise.
Defined at:
Codex:

Checks whether auto-updates are forced for an item.



Source

function wp_is_auto_update_forced_for_item( $type, $update, $item ) {
	/** This filter is documented in wp-admin/includes/class-wp-automatic-updater.php */
	return apply_filters( "auto_update_{$type}", $update, $item );
}